OS 4.0 installeren: Doen of niet?
Redactie

Toen gisteren OS 4.0 uitkwam gingen tweeps als gekken te werk. Bèta’s van de nieuwe firmware zijn te downloaden bij Apple voor ontwikkelaars. Tweeps vroegen aan elke ontwikkelaar of ze de bèta versie mochten hebben omdat ze niet kunnen wachten tot juni. Ik was één daarvan. Al gauw had ik een developer te pakken waar ik ook bèta versies van applicaties van test. Tijdens het mailen met hem kwam ik tot een aantal verontrustende opmerkingen.

Een bèta kan aflopen. Als je geen nieuwere bèta installeert dan is je iPhone onbruikbaar. Als de developer die je kent elke keer de nieuwe firmware naar je wil sturen dan is er niets aan de hand. Maar stel dat jij een dag niet bij de computer kan. Of dat de ontwikkelaar geen tijd heeft om hem te downloaden en te versturen. Dan zit je een poosje met een mooie iPhone die niet werkt.

iPhone OS 4.0 zou buggy zijn. Volgens verschillende mensen die OS 4 al wel geïnstalleerd hebben loopt de iPhone vaak vast en moet hij gereboot worden. Dit is natuurlijk erg als je het als je gebruiker bent en geen developer. Dan wil je natuurlijk een goed werkende telefoon en niet eentje die niet werkt.

Nog niet alle applicaties werken op OS 4.0. Er is waarschijnlijk nog geen applicatie te vinden die al geoptimaliseerd is voor 4.0. Een aantal applicaties werken wel maar dat is puur geluk. Richting de zomer zullen er steeds meer ontwikkelaars zijn die de applicaties gereed maken voor dit nieuwe OS van Apple.

Tot die tijd kan je het beste even wachten met het installeren van de bèta tot dat de tweede versie er is. Het beste is natuurlijk om 3.x.x te blijven draaien maar veel mensen kunnen niet wachten.

Draag ook bij aan dit artikel

Deel je kennis of stel een vraag. Dat kan anoniem of met een Disqus account.